What version of TritonWear Live do I need to have kick support?

In order for kick support to work, you will need to ensure you have TritonWear Live v1.1.13 or later installed on your iPad.

Furthermore, if you install firmware v1.3.0 on either your Triton Units or Triton Connects, without also updating your TritonWear Live application to v1.1.13 or later, there will be significant impact to the overall functionality of the platform.

If you have any questions, or require any assistance, please do not hesitate to reach out to us at support@tritonwear.com