What versions and operating systems are required for my devices to run TritonWear?

In order to run the TritonWear system, please ensure all of your devices and operating systems meet the minimum requirements for each of TritonWear Live, TritonWear Insights, and TritonWear Update.

TritonWear Live minimum requirements:

  • Bluetooth Low Energy Compatible iOS device
  • iOS: iPad 4 or later

Download TritonWear Live for iOS.

TritonWear Insights minimum requirements:

  • Current and last 2 versions of Chrome, Mozilla, Safari, Microsoft Edge, (and Internet Explorer 10.0 or later).

Log in to TritonWear Insights

TritonWear Update minimum requirements:

  • OSX 10.8 (Mountain Lion) & Windows 7 and later
  • Current and last 2 versions of Chrome, Mozilla, Safari, Microsoft Edge, (and Internet Explorer 10.0 or later).

Download TritonWear Update for Mac

Download TritonWear Update for Windows